Fiat twin cam problems

For general chat, questions etc about cars designed by JP - the main forum
Carl55
Posts: 37
Joined: Sat Jul 27, 2019 10:01 am
Name: Carl Dorling

Fiat twin cam problems

Postby Carl55 » Sun Nov 10, 2019 8:13 pm

Hi all does anyone have any idea why my cam belt is trying to run off the pulleys new belt and tensioner same problem with the old belt .

User avatar
RedStar
Posts: 120
Joined: Fri Apr 25, 2014 11:13 am
Name: Karl Davies
Location: South Wales

Re: Fiat twin cam problems

Postby RedStar » Sun Nov 10, 2019 10:13 pm

people asking on Guy Croft's forum - http://www.guy-croft.com/viewtopic.php?t=897

I saw that when the tension is too big,the cam belt goes to the motor,and when the cam belt tension is too low,it goes outside to the right side of the car.


might be something easy to check/change?
Sylva Star 2L Fiat Twincam with Twin Weber 40 DCOE
Currently being restored after 10 years standing

User avatar
RedStar
Posts: 120
Joined: Fri Apr 25, 2014 11:13 am
Name: Karl Davies
Location: South Wales

Re: Fiat twin cam problems

Postby RedStar » Mon Nov 11, 2019 9:32 am

http://www.guy-croft.com/viewtopic.php?t=25

1. Incorrect layout of pulley flanges *
2. Crank, cam, auxiliary driveshaft end float
3. Taper worn on crank nose pulley or cam pulley (s)
4. Cam nose length wrong (I have seen this once, fortunately before I fitted the cam)
5. Cam or crank pulley (s) not seating properly.
6. Cam pulley 'swashing' ie: cam nose not perpendicular to axis (bad grind) *
7. Badly worn tensioner bearings
8. Badly worn aux d/s or bearings especially the rear journal (shaft runs on a slant) *

* means I have actually seen belt wander & wear due to that cause.
Sylva Star 2L Fiat Twincam with Twin Weber 40 DCOE
Currently being restored after 10 years standing

User avatar
RedStar
Posts: 120
Joined: Fri Apr 25, 2014 11:13 am
Name: Karl Davies
Location: South Wales

Re: Fiat twin cam problems

Postby RedStar » Mon Nov 11, 2019 7:24 pm

http://www.fiatspider.com/f15/viewtopic.php?t=19297

As it happens it was the aux pulley, the way it was worn. A `new` second hand one has been fitted, with a guard on the backside. Belt now runs completely central on the pulleys.
Sylva Star 2L Fiat Twincam with Twin Weber 40 DCOE
Currently being restored after 10 years standing

Carl55
Posts: 37
Joined: Sat Jul 27, 2019 10:01 am
Name: Carl Dorling

Re: Fiat twin cam problems

Postby Carl55 » Sun Dec 22, 2019 1:10 pm

Hi just a update on the fiat Twincam problem after much reading and checking I found several reasons why the timing belt was running off, first the previous owner had failed to replace a very worn toothed crank gear coupled with dirt between the auxiliary shaft and it’s toothed wheel plus he had spray painted the whole engine including the toothed wheels . Once this was cleaned off and a new bottom crank gear fitted hey presto all good oh forgot to mention the belt tension pulley needed replacement and cleaned behind the bracket.

User avatar
RedStar
Posts: 120
Joined: Fri Apr 25, 2014 11:13 am
Name: Karl Davies
Location: South Wales

Re: Fiat twin cam problems

Postby RedStar » Sun Dec 22, 2019 6:44 pm

wow. glad you got it sorted!
Sylva Star 2L Fiat Twincam with Twin Weber 40 DCOE
Currently being restored after 10 years standing


Return to “Jeremy Philips Cars”

Who is online

Users browsing this forum: No registered users and 2 guests